frame relay switch

6
CONFIGURING THE FRAME RELAY SWITCH STEP 1. Change the router's name to frame-switch Enter configuration mode by using the following command: Router# configure terminal Change the host name of the router to frame-switch by using the following command: Router(config)# hostname frame-switch STEP 2. Enable the router to become a frame-relay switch Configure the router to act as a frame relay switch by using the following command: frame-switch(config)# frame-relay switching STEP 3. Configure the frame relay switch's interfaces Enter interface configuration mode for the first connected serial interface, e.g. serial 0: frame-switch(config)# interface serial 0 Remove the IP address: frame-switch(config-if)# no ip address Set the clock rate to 64000: frame-switch(config-if)# clock rate 64000 Set the encapsulation type to Frame Relay: frame-switch(config-if)# encapsulation frame-relay Set the LMI type to ANSI: frame-switch(config-if)# frame-relay lmi-type ansi Set the Frame Relay interface type to dce: frame-switch(config-if)# frame-relay intf-type dce Enable the interface: frame-switch(config-if)# no shutdown Repeat the commands above for the other connected interfaces on the frame relay switch.

Upload: subhrendu-guha-neogi

Post on 31-Aug-2014

32 views

Category:

Documents


0 download

TRANSCRIPT

Page 1: Frame Relay Switch

CONFIGURING THE FRAME RELAY SWITCH

STEP 1. Change the router's name to frame-switch

Enter configuration mode by using the following command:

Router# configure terminal

Change the host name of the router to frame-switch by using the following command:

Router(config)# hostname frame-switch

STEP 2. Enable the router to become a frame-relay switch

Configure the router to act as a frame relay switch by using the following command:

frame-switch(config)# frame-relay switching

STEP 3. Configure the frame relay switch's interfaces

Enter interface configuration mode for the first connected serial interface, e.g. serial 0:

frame-switch(config)# interface serial 0

Remove the IP address:

frame-switch(config-if)# no ip address

Set the clock rate to 64000:

frame-switch(config-if)# clock rate 64000

Set the encapsulation type to Frame Relay:

frame-switch(config-if)# encapsulation frame-relay

Set the LMI type to ANSI:

frame-switch(config-if)# frame-relay lmi-type ansi

Set the Frame Relay interface type to dce:

frame-switch(config-if)# frame-relay intf-type dce

Enable the interface:

frame-switch(config-if)# no shutdown

Repeat the commands above for the other connected interfaces on the frame relay switch.

Page 2: Frame Relay Switch

STEP 4. Configuring the end-point routers and their interfaces

Change the host name of the router to 2501-A, 2501-B, or 2501-C, as shown in the network diagram by using the following

command:

Router(config)# hostname 2501-A

Enter interface configuration mode for the connected serial interface:

2501-A(config)# interface serial 0

Assign the IP address as shown in the diagram (ie. for router 2501-A, use 10.10.12.2 with subnet 255.255.255.240):

2501-A(config-if)# ip address 10.10.12.2 255.255.255.240

Set the encapsulation type to Frame Relay:

2501-A(config-if)# encapsulation frame-relay

Set the LMI type to ANSI:

2501-A(config-if)# frame-relay lmi-type ansi

Enable the interface:

2501-A(config-if)# no shutdown

Repeat the steps above for the other end-point routers.

STEP 5. Verify your progress

On the frame-switch, use the show interface command to verify the operation for all connected interfaces. The output should be as

following:

frame-switch# show interface serial 1

STEP 6. Configure DLCI mappings

Now we need to configure the DLCI mappings for each interface by using the frame-relay route command. The format for this

command is:

frame-switch(config-if)# frame-relay route <input dlci> interface <output interface> <output dlci>

You need to configure the appropriate mappings on all the connected interface on the frame relay switch. Following are the

commands that need to be configured for our example network.

frame-switch#configure terminal

frame-switch(config)# interface serial 1

frame-switch(config-if)# frame-relay route 100 interface s3 101

frame-switch(config-if)# frame-relay route 300 interface s2 301

frame-switch(config-if)# interface serial 2

frame-switch(config-if)# frame-relay route 201 interface s3 200

frame-switch(config-if)# frame-relay route 301 interface s1 300

frame-switch(config-if)# interface serial 3

frame-switch(config-if)# frame-relay route 200 interface s2 201

frame-switch(config-if)# frame-relay route 101 interface s1 100

STEP 7. Verify configuration and connection

Go to one of the endpoints and look at the output of some of the "show frame-relay" commands. You can see the DLCI mappings

have propagated to the endpoints. You don't need to set them up on the endpoints, only on the switch.

Display the frame relay DLCI mappings by using the following command:

2501-A# show frame-relay map

Display the frame relay pvc statistics by using the following command:

2501-A# show frame-relay pvc

2501-A# ping 10.10.12.3

Page 3: Frame Relay Switch

2501-A# ping 10.10.12.4

frame-switch# show frame route

This first CCNA TechLab covers a couple of basic configuration tasks, such as setting passwords and enabling IP routing using RIP.

You will need a lab setup similar to the network diagram below:

Before you start, make sure you clear both routers' configuration using the Router#erase startup-config command.

First we will configure RouterA, after the router reboots, the following message will be displayed:

Type no and press ENTER. Press ENTER again when the message Press RETURN to get started appears. Type enable

at the Router> command prompt to enter Privileged Exec mode, notice the prompt chances to Router#.

CONFIGURING THE FIRST ROUTER

STEP 1. Change the router's host name to RouterA

Enter configuration mode using the following command:

Router#configure terminal

Change the host name of the router to RouterA using the following command :

Router(config)#hostname RouterA

RouterA(config)#

Notice how changing the hostname immediately affects the prompt. Remember that you are configuring the running

configuration.

STEP 2. Disable domain lookups

To prevent the router from interpreting every incorrectly typed command as a host name and trying to resolve it to

an IP address to setup a telnet connection with it, use the following command:

RouterA(config)#no ip domain-lookup

STEP 3. Configure passwords

First set the enable password to cisco123 using the following command:

RouterA(config)#enable secret cisco123

Page 4: Frame Relay Switch

Next, set the password for telnet connections to cisco456 using the following commands:

RouterA(config)#line vty 0 4

RouterA(config-line)#password cisco456

RouterA(config-line)#login

Although the enable secret command is used to encrypt the enable password, other passwords stored in the router's

configuration should be encrypted as well. To do this, use the following command:

RouterA(config)#service password-encryption

STEP 4. Configuring the Ethernet interface

Enter Interface configuration mode for the Ethernet interface, using the following command:

RouterA(config)#interface Ethernet 0

Give it the description "Connected to LAN" using the following command:

RouterA(config-if)#description Connected to LAN1

Configure the IP address (see diagram for correct address) for the interface using the following command:

RouterA(config-if)#ip address 192.168.11.1 255.255.255.0

Enable the interface using the following command:

RouterA(config-if)#no shutdown

STEP 5. Configure the serial WAN interface

Switch to Interface configuration mode for the first Serial interface, using the following command:

RouterA(config)#interface Serial 0

Give it the description "Direct connection to RouterB" using the following command:

RouterA(config-if)#description connected to RouterB

Configure the IP address (see diagram for correct address) for the interface using the following command:

RouterA(config-if)#ip address 192.168.22.5 255.255.255.0

Configure the interface to use PPP encapsulation using the following command:

RouterA(config-if)#encapsulation ppp

Enable the interface using the following command:

RouterA(config-if)#no shutdown

STEP 6. Configure RIP

Use the following command to enable RIP on RouterA:

RouterA(config)#router rip

Configure the router to receive and send only RIP Version 2 packets using the following command:

RouterA(config-router)#version 2

Use the following commands to specify the networks directly connected to the router:

Page 5: Frame Relay Switch

RouterA(config-router)#network 192.168.11.0

RouterA(config-router)#network 192.168.22.0

STEP 7. Save configuration

To copy the currently running active configuration to NVRAM, so it will be used the next time you reload the router,

use the following command:

RouterA#copy running-config startup-config

STEP 8. Configuration second router

To configure the other router, RouterB, repeat the steps above. Use the network diagram to determine the correct

addressing and names. To enable the back-to-back serial connection between te routers, you need to configure one

router as DCE using the following command in Interface configuration mode for the serial connection on RouterB:

RouterB(config-if)#clock rate 64000

STEP 9. Verify and test the configuration

Verify using the ping command Host A to Host B, make sure you configured both hosts to use the nearest router's

interface as the default gateway in the TCP/IP settings.

On both routers, run the following command in Privileged Exec mode to determine which device is the DCE:

Router#show controllers s0

On one of the routers, run the following command in Privileged Exec mode to display the parameters and current

state of the active routing protocol process, and examine the output:

Router#show ip protocols

Use the following command to verify routing table entries on both routers:

Router#show ip route

Use the following command to list a summary of the interface's IP information and status on both routers, and

examine the output:

Router#show ip interface

Use the same command with the brief option, and the notice output:

Router#show ip interface brief

R1 -

int s0/0

no ip address

encapsulation frame-relay

int s0/0.23 multipoint

description PARTIAL-MESH CONNECTION TO R2-R3

ip add 192.168.23.1 255.255.255.248

encapsulation frame-relay

frame-relay map ip 192.168.23.2 102 broadcast

Page 6: Frame Relay Switch

frame-relay map ip 192.168.23.3 103 broadcast

int s0/0.4 point-to-point

description P2P CONNECTION TO R4

ip add 192.168.14.1 255.255.255.252

encapsulation frame-relay

frame-relay interface-dlci 104

R2 -

int s0/0

no ip address

encapsulation frame-relay

int s0/0.23 multipoint

description PARTIAL-MESH CONNECTION TO R1-R3

ip add 192.168.23.2 255.255.255.248

encapsulation frame-relay

frame-relay map ip 192.168.23.1 201 broadcast

frame-relay map ip 192.168.23.3 203 broadcast

R3 -

int s0/0

no ip address

encapsulation frame-relay

int s0/0.23 multipoint

description PARTIAL-MESH CONNECTION TO R1-R2

ip add 192.168.23.3 255.255.255.248

encapsulation frame-relay

frame-relay map ip 192.168.23.1 301 broadcast

frame-relay map ip 192.168.23.2 302 broadcast

R4 -

int s0/0

no ip address

encapsulation frame-relay

int s0/0.1 point-to-point

description P2P CONNECTION TO R1

ip add 192.168.14.2 255.255.255.252

encapsulation frame-relay

frame-relay interface-dlci 401