router configuration in packet tracer

Post on 16-Jul-2015

233 Views

Category:

Internet

3 Downloads

Preview:

Click to see full reader

TRANSCRIPT

Router Configuration in Packet Tracer

12/14/2014router configuration

1

Packet Tracer

• Packet Tracer is a program used to illustrate at a basic level how networks work

• At startup, you are in the Logical Workspace in Realtime Mode

• You can build your network and see it run in real time in this configuration

12/14/2014router configuration

2

12/14/2014router configuration

3

Organization of Packet Tracer

• Packet Tracer has two different views

• Logical Workspace

• Physical Workspace

12/14/2014router configuration

4

Router

•Router is a device which makes connection possible

between two or more different networks present at same

or different geographical locations.

•It works on 3rd layer of OSI Model(i.e on network layer)

•It does two basic things:.

1. Select the best path from the routing table.

2. Forward the packet on that path.

12/14/2014router configuration

5

Router pictures

12/14/2014router configuration

6

Vendors of Router

Many companies are manufacturing routers

• Cisco• Nortel• Multicom• Juniper• Dlink• 3com

12/14/2014router configuration

7

Cont…

• Cisco is the leading manufacturer of routers and

switches .

• It manufactures 70% of routers and switches of the

market.

12/14/2014router configuration

8

Ports on Router

There are three types of ports on the router.

1. LAN ports

2. WAN ports

3. Administrative Ports

12/14/2014router configuration

9

Modes of the Router

• Here are different modes of the router

• Setup Mode

• User Mode

• Privileged Mode

• Global Configuration Mode

• Interface Mode12/14/2014router configuration

10

Cont….

Setup Mode

• The router enters in to the setup mode if the NVRAM is empty.

Continue with configuration dialog[yes/no]

Answer with ‘Yes’ or ‘No’.

User Mode

• Only some basic monitoring

• Limited show commands ping, trace,

• Router> 12/14/2014router configuration

11

Cont…

Privileged Mode

• Monitoring and some troubleshooting.

• All show commands, ping trace, copy and erase

• Router#

Global Configuration Mode

• To make any change that affect the router like hostname, routing configuration.

• Router(config)#12/14/2014router configuration

12

Cont…

• Global Configuration Mode

• Configurations done on the specific interface.

• Router(config-if)#

• Rommon Mode

• Reverting Password

12/14/2014router configuration

13

Basic Commands

• Setup Mode

• Continue with configuration dialog?[Yes/No]

• Answer ‘Yes’ or ‘No’.

• User Mode

• Router>

• Router>enable

12/14/2014router configuration

14

Privileged Mode

• Router#Show running-config

• Router#Show start-config

• Router#Show flash

• Router#Show version

• Router#Show ip interface brief

12/14/2014router configuration

15

Global Configuration Mode

• Router#Configure Terminal

• Router(config)#Hostname R-1

• R-1(config)#Show IP route

• R-1(config)enable password<password>

• R-1(config)enable secret <password>

12/14/2014router configuration

16

Interface Mode

• Router(config)# interface FastEthernet0/0

• Router(config-if)#ip address <ip address> <Subnet Mask>

• Rouetr(config)#interface Serial 0/0

• Router(config-if)ip address <ip address> <Subnet Mask>

12/14/2014router configuration

17

Routing

•Forwarding the packets from one network to the other network choosing the best path from the routing table.

•Routing makes possible for two or more networks to communicate with each other

•Routing table only consist of only the best routes for each destination

12/14/2014router configuration

18

Types of routing

1. Static routing

2. Dynamic routing

12/14/2014router configuration

19

Static Routing

• It is configured manually by the administrator.

• Mandatory need for the destination network ID

• Used for small organizations

• In static routing the administrator decide the best path

• Administrator should know that what is the destination ID and how many routes to reach that destination

12/14/2014router configuration

20

Advantages

• There is no overhead on the router CPU.

• There is no bandwidth usage between the routers

• It adds security because the administrator can choose to allow routing access to the certain networks only

12/14/2014router configuration

21

Disadvantages

• Used for small network(its not feasible in large networks)

• Each and every network have to manually configured.

• Any change in the network has to be update in all routers.

12/14/2014router configuration

22

Configuring the Static Routing

• Router(config)#ip route <Destination Network ID>

• <Destination Subnet Mask>

• <Next Hop IP address>.

12/14/2014router configuration

23

Example:

12/14/2014router configuration

24

Code of example:

• For PC1:

• IP address 10.0.0.2 Subnet mask 255.0.0.0 Default Gateway 10.0.0.1

• For PC2 :

• IP address 30.0.0.2 Subnet mask 255.0.0.0 Default Gateway 30.0.0.1

12/14/2014router configuration

25

Cli code:

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>

Set Hostname to R1 and assign 10.0.0.1 255.0.0.0 ip address to fast Ethernet 0/0.

also set a message “ Unauthorized access is prohibited”.

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#banner motd # Unauthorized access is prohibited #

R1(config)#interface fastethernet 0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#

12/14/2014router configuration

26

configure serial portWhen Serial connections are configured they need one more command that normal

Ethernet connections do not. That command is theclock rate command.

Establish a simple serial to serial connection between R1 Serial 0/0/0 and R2 Serial

0/0/0.

Now configure serial port on both router with ip address 20.0.0.1 255.0.0.0 on one and

20.0.0.2 255.0.0.0 on two.

On R1:

R1(config)#interface serial 0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#bandwidth 64

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R1(config-if)#exit

R1(config)#12/14/2014router configuration

27

First tell R1 about to network of 30.0.0.0

R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2

R1(config)#

In this command 30.0.0.0 is the destination network and 255.0.0.0 is the

subnetmask on destination network and 20.0.0.2 is the ip address of next

hope

12/14/2014router configuration

28

Configure Router-2 :hostname R2 and 30.0.0.1 255.0.0.0 ip address on

fast Ethernet 0/0.

Router>enable

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,

changed state to up

R2(config-if)#exit

R2(config)#12/14/2014router configuration

29

Configure serial port

On R2

R2(config)#interface serial 0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#exit

Say this way "To get to the destination network of 30.0.0.0, with a subnet

mask of 255.0.0.0, send all packets to 20.0.0.2"

Now tell R2 about to network of 10.0.0.0

R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

R2(config)#

12/14/2014router configuration

30

12/14/2014router configuration

31

12/14/2014router configuration

32

top related